Monero-Javascript doesnt work on latest version of NodeJS

Monero-Javascript doesnt work on latest version of NodeJS
spederan
0
0

Monero-Javascript doesnt work on latest version of NodeJS

As a Javascript developer and I want to build on Monero, but as of right now it doesnt seem like the available software is maintained enough for me to build on it. The last commit i see on github was 3 months ago and theres problems with it today. It seems due to IPV4/6 address handling, NodeJS >17 is breaking monero-javascript. Its been a week since the issue was discovered. Can someone fix this?

See thread:

https://github.com/monero-project/monero/issues/8646

https://github.com/nodejs/node/issues/40702#issuecomment-966968102